How to create a navigation mesh

Ask questions about mapping in general, and show off your in-progress work.
User avatar
icaro440
Marauder
Posts: 172
Joined: Fri Mar 23, 2012 10:46 am UTC
Location: [SP]ain

How to create a navigation mesh

Postby icaro440 » Fri Oct 11, 2013 1:58 pm UTC

hello again guys, I have a problem with the navigation mesh generation for testing bots on my map, this is the first time I try to make one. I'm using windows xp (virtual machine), and I'm following this tutorial.

https://unvanquished.net/wiki/index.php ... Jump_Links


The problem is that nothing happens, even one of the parameters is not recognized.

Image

Could anyone tell me what am I doing wrong?
User avatar
Viech
Project Head
Posts: 2137
Joined: Fri Aug 03, 2012 11:50 pm UTC
Location: Berlin

Re: How to create a navigation mesh

Postby Viech » Fri Oct 11, 2013 2:36 pm UTC

Did you use the windows installer or compile from source?

It is possible that we accidentially packed a pre-bot-merge daemonmap or that you compiled a branch without bots or disabled building of dameonmap at some point, resulting in an outdated version that doesn't yet know about bot related features.
Responsible for: Arch Linux package & torrent distribution, Parpax (map), Chameleon (map texture editor), Sloth (material file generator), gameplay design & programming, artistic direction
User avatar
Fuma
Programmer
Posts: 58
Joined: Wed Mar 07, 2012 6:49 pm UTC

Re: How to create a navigation mesh

Postby Fuma » Fri Oct 11, 2013 2:45 pm UTC

Hi
I'm the one who created the bots.

That wiki page is very out of date now.
I'll update it later today.

You don't seem to be doing anything wrong that I see, but the utility seems to be ignoring the -nav parameter.
Make sure you are using the latest release, and try again without -game unv since -game unv is the default.
User avatar
icaro440
Marauder
Posts: 172
Joined: Fri Mar 23, 2012 10:46 am UTC
Location: [SP]ain

Re: How to create a navigation mesh

Postby icaro440 » Fri Oct 11, 2013 3:48 pm UTC

Hey guys, thanks for the quick response.

Initially I tried to create the mesh using version 12, (yes yes, I know, but what do you expect from a guy like me, who still uses windows xp :))

Just try it with version 20, with the same results.

Viech: I have not compiled anything, pure windows installer.

Fuma: I also tried it without the parameter-game unv, obtaining the same results. Man, thank you for the bots. :thumbup: :thumbup:

Ok, no problem, just wanted to kill a few defenseless grangers in the disastrous map I'am making :grin: :grin:

I guess I have to wait for future versions to satisfy my dark desires. I have no hurry.

You guys have done a great job. :beer:

Return to “Level Design”

Who is online

Users browsing this forum: No registered users and 2 guests