Page 1 of 2

Software freedom strikes again!

Posted: Fri Mar 06, 2015 6:43 am UTC
by lamefun
- Visited NetRadient page. Of course, no pre-built packages for Fedora. Diversity and "freedom" for all! May GNOME developers, God bless them and their work, finish its sandboxed universal cross-distro bundle system before it's too late for "free" software!

- Quake2WorldPack server wasn't responding. And guess what, Ctrl+C wouldn't stop SVN from trying to connect. Excellent! I had to wait for the timeout, because otherwise NetRadiant wouldn't launch, since the rule to place version-files executes after gamepack downloads.

- Game pack on NetRadiant site was outdated, tried to search in main instead of pkg and .Unvanquished instead of .unvanquished. Took me a while to figure out that there's mapeditor-support repository...

- Map refused to launch with apparently no error. I forgot player intermission and alien spawn, but even after fixing this map refused to launch. Guess what? Console was cleared every time! It's only because I launched the game in real terminal and scrolling back I found the error, it was a typo in DEPS file.

- I want a tree, wanted to try to make one in Blender, curves seemed to be a perfect tool for this. There's bevel (with controllable shape, even!), but seemingly no way to control its thickness. But there is one, Alt+S, nowhere to be found in menus, I had to search Blender wiki to find it... And immediately I hit some bizzare bug that made it work only half the time...

Bloody hell... How do you work with these "free" tools at all? No wonder all models come from people with PROprietary background using PROprietary tools...

PROprietary software rocks! PRO! PRO! DRM protects! Human culture is safe!

Re: Software freedom strikes again!

Posted: Fri Mar 06, 2015 9:27 pm UTC
by kharnov
We can't do anything about Radiant or Blender since we don't maintain either, but maybe it would be a good idea for us to start packaging the latest Radiant with the relevant game files.

Re: Software freedom strikes again!

Posted: Sat Mar 07, 2015 1:34 am UTC
by illwieckz
but maybe it would be a good idea for us to start packaging the latest Radiant with the relevant game files.

Please no!

Let's welcome:
  • AARadiant (from Alien Arena project, NetRadiant fork)
  • CoDRadiant (from Call of Duty project)
  • DarkRadiant (from The Dark Mod project, for Doom 3 engine based games, GtkRadiant 1.5.0 fork)
  • Embrace (from Vampire: The Masquerade – Redemption project, part of Nod SDK, QERadiant fork)
  • ETXRadiant (from ET:XreaL project, DarkRadiant fork)
  • GtkRadiant (the 1.4/1.6 branch, multiplatform port of QERadiant using GTK gui toolkit instead of MFC one)
  • GtkRadiant (the 1.5 branch)
  • HMF2Radiant (from Heavy Metal: FAKK2 project, part of FAKKTools, the binary is named Q3Radiant, and advertises itself as QERadiant in some places)
  • KpRadiant (from Kingpin: Life of Crime project, remaining web pages makes strong references to QERadiant)
  • MacRadiant (GTKRadiant port to Mac OS X)
  • MoHRadiant (MOHAATools, from Medal of Honnor: Allied Assault project, QERadiant fork)
  • NetRadiant (community fork of GTKRadiant 1.5, advertised as “A Stabilized Q3 Map Editor” in former icculus' repository with a former website hosted by Alien Trap, now hosted and somewhat maintained by the Xonotic team)
  • NetRadiant Custom (fork by Garux, hard to merge)
  • ODRadiant (from OverDose project, there is some GTKRadiant traces in it)
  • OWRadiant (from OWEngine project, an unfriendly renamed Qio Engine copypaste namesquatting the former OpenWolf project)
  • QERadiant (original public radiant based on QE4, QE stands for Quake Ed the in-house editor for Quake¹, QE4 was the in-house Quake 2 level editor)
  • Q3Radiant (former name for QERadiant, in-house Quake 3 level editor)
  • QioRadiant (from Qio Engine project)
  • QtRadiant (the one by Ensiform)
  • QtRadiant (the one by Radegast)
  • Radiant (from Doom 3 source tree)
  • SDRadiant (from Wolfenstein: Enemy Territory project, SD stands for Splash Dammage)
  • SoFRadiant (from Soldier of Fortune project)
  • ÜberRadiant (from Star Trek: Elite Force 2 project, Über stands for ÜberGames)
  • UFORadiant (from UFO:AI project, based on an old DarkRadiant fork)
  • VolatileRadiant (from Volatile3D II project, XaeroX said it is based on Q3Radiant, also named VolatileLevelDesignSDK)
  • VRadiant (from Vecxis project, NetRadiant fork)
  • WolfRadiant (from ET:Legacy project)
  • XreaLRadiant (from XreaL project)
  • ZeroRadiant (code name for GTKRadiant 1.6 which is a successor to GTKRadiant 1.4)
And soon:
  • DæmonRadiant
  • YetAnotherRadiant
I'm pretty sure I forget something.

There is no NetBlender, no GTKBlender, no DarkBlender, no XreaLBlender.

If you need to package it, it means there is something wrong elsewhere.

¹ Fun stuff, QuakeEd (from which the QE in QERadiant comes from) was running on NextStep, so everytime you write down the "qer_editorimage" keyword in a shader, it's because of that 20 years old in-house Quake level editor running on NextStep.

Re: Software freedom strikes again!

Posted: Sat Mar 07, 2015 2:16 am UTC
by lamefun
illwieckz wrote:...

If this isn't sarcasm, there's no hope for "free" software...

Re: Software freedom strikes again!

Posted: Sat Mar 07, 2015 3:16 am UTC
by lamefun
OK, so curve point scaling didn't work half the time because I pressed S before Alt. Still, why is it Alt+S instead of just S? S seemingly does nothing (and most probably does nothing too, since you can't actually "scale" infinitely small points.

Re: Software freedom strikes again!

Posted: Sat Mar 07, 2015 9:23 am UTC
by chris
No need to work with curves if blender has a full featured tree generator called Sapling.
phpBB [video]

Or use tree[d]
phpBB [video]

Re: Software freedom strikes again!

Posted: Sat Mar 07, 2015 9:58 am UTC
by lamefun
I want some specific shapes, so I'll only use sapling for branches.

There's also NGPlant, but I'll compile it later (developer didn't make packages for Linux for obvious reasons, nice "diversity", "choice", distro makers, nice job destroying "free" software, spawning rotten fruit and nothing else).

Your videos won't work, probably because phpBB assumes Flash installed, which I don't have. See? Even "open" source developers assume PRO!

And Sapling isn't even "fully featured", look what dirty tricks you have to resort to just to add fruits! ... ling-addon

Also you have to resort to dirty tricks to use custom objects for leaves.

Leaf count field won't work. If it's greater than zero, leaves appear, if it's zero, leaves disapper. I can't control the number of leaves at all.

Saving presets won't work either, so I have to do everything all over again every time...

Can't compile NGPlant either: ambiguous conversion from const char * to const wsString... will probably have to fix code problems too.

Apparently, NGPlant needs wxWidgets 3.0, but build system still thinks that 2.8 is enough...

# yum install wxGTK3-devel
$ scons -c
$ rm -f .sconsign.dblite
$ scons WX_CONFIG=wx-config-3.0

OK, now I can launch it, tried to change random seed... Assertion failed dialogs, LOTS of them!

So, the lesson is clear: use PROprietary software, use PRO! It's protected by DRM!

Even when using "open" source software, use Windows! Even "open" source developers care more about PRO than about their fellow "open" source platforms.

Re: Software freedom strikes again!

Posted: Sun Mar 08, 2015 7:38 am UTC
by lamefun
Awesome! There was once a nice add-on that allowed to generate twigs on pre-existing branches (, but now it's gone. That's how it is in "open" source.

Re: Software freedom strikes again!

Posted: Sun Mar 08, 2015 11:03 am UTC
by Viech

Re: Software freedom strikes again!

Posted: Sun Mar 08, 2015 11:25 am UTC
by lamefun
I had to switch from Ubuntu to Fedora because ibus loaded 100% CPU when I started to type in GEdit, making it impossible to type anything...

Saving presets probably didn't work in version I installed from Fedora repositories because Sapling tried to save presets directly into /usr/share/blender... That's how "open" source is written... Also it doesn't allow to remove presets...

Blender 2.73a has been released, with bugfixes... Fedora still ships Blender 2.73.